Social Inquiry Planner

About this tool

Accessibility

Supported browsers

This online tool has been built to enable teachers and students to more efficiently carry out the social inquiry planning process. To do this it uses a range of modern web technologies that allow for more complex interactivity between the user and the tool.

Unfortunately a number of these technologies are not supported by older web browsers, and whilst every effort has been made to provide alternative behaviours for these browsers, the tool works best in the following modern browsers:

Under Windows XP, Vista or 7:

  • Internet Explorer 7 and 8
  • Firefox 2, 3 or 3.5
  • Safari 4

Under Mac OS X

  • Safari 3 or 4
  • Firefox 3

If you can interact with the tool using one of these browsers, it is strongly recommended to do so.

If you use the tool in a common older browser such as Internet Explorer 6, which was released in 2001, or Safari 2, which was released in 2005, you will see an alternative version of the tool. You will still be able to use the main interactive components but the display and usability are not as advanced, and you will be missing out on some key usability features.